CLOSE MENU
GREEN WEBSITE HOSTING. DONE RIGHT

WordPress has detected that your site is running on an insecure version of PHP

When logging into your Wordpress website admin panel I see "WordPress has detected that your site is running on an insecure version of PHP"

This is a message added by WordPress to alert you that the version of PHP you are running is an older version.

Can I change the version of PHP that my cPanel hosting account is using?

You can and multiple PHP versions are available on server to choose from at any time.

How do I do that?

Just login to your cPanel account and go to section SOFTWARE and choose option “MultiPHP Manager”, once there select the domain and on the right side choose the PHP version you require from drop down menu and press apply.

Useful information: –

From MultiPHP Manager you can set the PHP version per domain or across your whole hosting package.

If you encounter any issues with your site not displaying correctly after changing the version of PHP in use it is likely you are running a plugin or theme that is not compatible with the newer version of PHP you have selected and you may need to lower it or contact the plugin or theme authors for advice.

You can always change the PHP version back to the original version in the meantime to have your site display correctly again whilst you investigate.